sobota, listopada 06, 2010

Bug w debugu ;-)

Dziś obejrzymy fascynujący film pokazujący "zabawnego" buga w debugowaniu w NetBeans 6.8 ;-)



Nie wiem czy to taki ficzer występujący tylko pod Windows 7, czy wszędzie, ale potrafi wkurzyć ;-)

Jakby ktoś nie programował a tu zajrzał, to tak wygląda często praca programisty. Przechodzi krok po kroku jakiś obszar kodu i patrzy jak program "idzie", jakie są wartości w zmiennych i próbuje zrozumieć "czemu do cholery to nie działa?!?!" ;-)

Fakt, zwykle jest milej o tyle, że całe środowisko uruchomieniowe tak nie miga.

Często człowiek siedzi parę godzin z debugerem i stara się wyszukać gdzie jest problem, by w końcu poprawić 1 linijkę kodu ;-)
Ja swego czasu w jednej z poprzednich firm spędziłem nad pewnym fragmentem kodu z tydzień, łącznie z tym, że usiadłem w końcu do niego z naszym architektem, a wszystko po to by się w końcu zorientować, że ktoś wcześniej pomylił i z j ;-)

A tutaj zanim pojawił się ten ciekawy efekt, próbowałem zdebugować OOo2GD i sprawdzić czy błąd który widziałem na LibreOffice rzeczywiście występuje czy mi się tylko wydawało :-)


Podobne postybeta
Książkowy Stack Overflow ;-)
Radość przedurlopowa - przycinanie ;-)
var bywa niebezpieczne :-)
Rammstein :-)
Leń

2 komentarze:

  1. :)
    Debugowanie kodu w assemblerze, najlepiej jeszcze cudzego jest jeszcze ciekawsze. Kiedyś lubiłem takie zabawy, choć nie mam do tego talentu.

    OdpowiedzUsuń
  2. Ja się na szczęście niewiele musiałem zajmować assemblerem (do teraz mam problem ze zrozumieniem działa rozkazu LEA w x86 ;-)) więc i debugowanie tam mi się bardzo rzadko zdarzało.
    No te 10-15 lat temu jak się assemblerem próbowałem bawić.

    OdpowiedzUsuń